GPS-Unit in Tokyo-Datum and Key Mappings.

Enter ideas to be considered for future versions.

Moderators: Scott, PathAway

j_h_h

GPS-Unit in Tokyo-Datum and Key Mappings.

Postby j_h_h » Sat May 21, 2005 3:25 pm

Hello.
I have been using PathAway for over one year and it works
very well.
Now I can not go out anywhere without PathAway. :-)

Palm : SONY CLIE PEG-SJ25 & PEG-TH55
OS : PalmOS 5.2.1
GPS : Earthmate USB + CLIE Cable (Datum = WGS84)
GPS : SONY GU-BT1 + Bluetooth Adapter HNT-BT1 (Datum = Tokyo)

I have several requests regarding GPS Protocol and Key Mappings.

1. GPS Protocol - Tokyo Datum
Recently, I have got SONY Bluetooth GPS-Unit GU-BT1 and I
just found out that it basically supports Tokyo-Datum only.
(Technically, it is possible to change the datum to WGS84,
but GU-BT1 can not hold the settings after turning power off.)
I know that re-calibrating the maps in Tokyo-Datum will solve
the problem, but I also want to use the same maps with Earthmate
GPS in WGS84-Datum.

So, if possible, please add the "Tokyo-Datum" to the list
in protocol settings of GPS preference screen.


2. Key Mappings - Jog Dial & Pageup-down Keys
Both CLIE PEG-SJ25 and PEG-TH55 have Jog Dials and Pageup-
down keys.
However, current version (3.01b33) doesn't respond at all
to those keys.

I think it would be very useful if we can modify the key
mappings of any input devices.


I'm looking forward to the next updating of PathAway.
Thank you very much.

CK

GPS-Unit in Tokyo-Datum and Key Mappings.

Postby CK » Fri Jun 10, 2005 10:59 am

Hi. I am now deciding whether to buy pathaway and the Sony GPS unit GU-BT1 for my TH55. The Calibrating function would make it much easier to prepare maps than using PalmGPS.

Do you know whteher there is any way to use any Japan digital maps on Pathaway?

(And "j_h_h" do you mind telling me how to change the datum to WGS84 on GU-BT1?)

Thanks.

CK

Postby CK » Sat Jul 16, 2005 10:48 am

j_h_h, can you tell me how you get the Sony GPS connected to your Th55? I can't make it work!

j_h_h

Postby j_h_h » Mon Jul 18, 2005 10:27 pm

CK wrote:j_h_h, can you tell me how you get the Sony GPS connected to your Th55? I can't make it work!






Hello, CK!

Do you use "HNT-BT1" bluetooth adapter?
Have you installed "BT Ada Utl" into your TH55?
Did you properly input the serial number of "HNT-BT1" to "BT Ada Utl"?

Please give me more detailed information, so I think I can help you.
:-)


Regarding the switching of datum from Tokyo to WGS, GU-BT1 has to be
connected
to PC and you need to send following commands by using terminal
software.
But, I've never tried this.

@SKA : To switch to WGS-84
@SKB : To switch to Tokyo

The datum will be reset to Tokyo when you turned the power off.

Good luck!

CK

Postby CK » Wed Jul 20, 2005 3:19 pm

Hi,j_h_h
It's great to see your reply. :D

Yes, I'm using "HNT-BT1" and I've installed "BT Ada Utl". I can use Leplan (the Japanese map application for "HNT-BT1") with the Sony GPS but cannot use the adapter and GPS with any other application.

Where do I input the serial number of "HNT-BT1" to "BT Ada Utl"? So far as I know, I have only input the serial no. of the GPS unit GU-BT1. But I don't see anywhere to input the no. of "HNT-BT1".

I've tried choosing both Serial and Cradle in the Pathaway Cinfigure GPS page but nothing happens. The LED of the "HNT-BT1" flashes red, which means it is not connected. If I choose Bluetooth on the Configure GPS page, the LED does not flash.

And when I launch the BT Adapter Utility and search for a unit, I can see SONY GPS GU-BT1 and the profile setting is DUN (which I cannot change to SSP). the LED flashes yellow and stops when I quit the utility application.

Can you tell me Which port you use for GPS on Pathaway and what happens when you tap "connect"?

Thank you.
Attachments
HRCapt20050716004245.jpg
HRCapt20050716004245.jpg (29.62 KiB) Viewed 14957 times

CK

Postby CK » Wed Jul 20, 2005 4:17 pm

By the way, I'm using Pathaway 3.01b35. Do you think the the version makes a difference?

j_h_h

Settings.

Postby j_h_h » Wed Jul 20, 2005 5:56 pm

Hello, CK!

Now I see the situation.
The profile setting has to be "SSP" to use GU-BT1 with PathAway.

Press [設定変更] button. (The LEFT button on the picture you attached.)
Press [Menu] button on the silk area.
Execute [プロファイル設定]. (The FIRST item on the drop-down list.)
Select "SPP".
Press [OK].
Press [設定]. (The LEFT button on the main screen of BT Ada Utl.
Press [OK].
Press [OK].

To use the GU-BT1 with PathAway, please check the following items
in the GPS Configuration Page.
- Protocol = NMEA
- Port = Serial or Cradle (Both will work.)
- Baud = 115200
- Parity = N
- Bits = 8
- Stop = 1

Does it work? :-)

And I've found the way to switch the GPS protocol from Tokyo
to WGS84 only with Palm application without PC.
If you are interested in it, please prepare PTelnet and install
it in your Palm.
I'll put the descreption within today.

See you!

Guest

Postby Guest » Wed Jul 20, 2005 11:48 pm

How to change the GPS protocol from Tokyo to WGS84 on GU-BT1

Equipment
- Palm : CLIE PEG-TH55 Japanese Version (SONY)
- GPS Receiver : GU-BT1 (SONY)
- BT Adaptor : HNT-BT1 (Hagiwara Syscom)
- GPS Software : Pathaway for Palm Ver. 3.01b35
- Terminal Software : P-Telnet (http://netpage.em.com.br/mmand/ptelnet.htm)

You need to use Terminal software to change the GPS protocol.
Followings are the procedure for P-Telnet.
P-Telnet is capable of VT100 terminal emulation and is a freeware.

I believe any Palm can change the GPS protocol only if the connection
with GU-BT1 has been established.
Also any Terminal software could access GU-BT1, however, it
seems that the connection baudrate has to be 115200.

1. Run the P-Telnet software on Palm.
2. Menu -> Options -> Serial
3. Port=Serial, Baud=115200 (Others as defaults.)
4. Menu -> Options -> Terminal
5. Mode=Serial (Change the font settings if you'd like.)
6. Menu -> Options -> Macros
7. Macro1=@SKA (Lower case is acceptable.)
8. Macro2=@SKB (Optional.)
9. Press Ok button in the left bottom of the screen to connect to GU-BT1.
10. Wait until you see the NMEA data from GU-BT1 on the screen.
11. While receiving the data, press Macro on the right buttom of screen.
12. Send Macro1 (@SKA).
13. IMPORTANT!! Send "Enter" graffiti command. (Write "/" on graffiti area.)
14. Confirm that the message of "@SKA" & "[SK] Done (WGS84)" appeared on the screen.
15. Press Ok button in the left bottom of the screen to disconnect.

Now the GPS protocol of GU-BT1 has been changed to WGS84 from Tokyo.
To put back the protocol to Tokyo, send the @SKB command in
the same way, or simply turn off & turn on the power of GU-BT1.

I hope that this information could be of help to you.
I live in Poland and I'm using this GU-BT1 without any problem. :-)

CK

Postby CK » Thu Jul 21, 2005 3:24 pm

Hi j_h_h,
It works! :D I once suspected that it was the problem with the SPP setting but I didn't realize that I can change the setting simply by using the "menu" button! How dumb :oops:
Thanks. Now I can try to calibrate my maps.

Guest,
Thank you for your information. It really helps a lot. I haven't used other GPS before but I found it very useful when I went to japan last month. Now I can use it in Hong Kong too. :lol: (See, I live in HK.)

j_h_h

Postby j_h_h » Sat Jul 23, 2005 9:39 am

Hello, CK!

I'm glad to hear you've finally scceeded. :-)
And the "Guest" who put the instruction about ptelnet was me.
(I just forgot to input my handle name.)

By the way, you can NOT use WGS84 datum when GU-BT1 is in "Standby
Mode".
Even if you get the message "[SK] Done (WGS84)", GU-BT1 will
not send proper signals.

See ya!

CK

Postby CK » Fri Aug 05, 2005 1:11 pm

Thank you.


Return to “PathAway for Palm OS - Suggestions”

Who is online

Users browsing this forum: No registered users and 1 guest