FIXED: Treo 680 new ROM 1.12 and PW4 Bluetooth connection

Forum for questions and problems regarding PathAway GPS 4 SE for Palm OS

Moderator: Scott

Scooby
Posts: 17
Joined: Tue Feb 06, 2007 12:23 am

FIXED: Treo 680 new ROM 1.12 and PW4 Bluetooth connection

Postby Scooby » Sat Feb 02, 2008 6:47 pm

PALM offers these days a new Treo FW (ROM 1.12 for USA and 2.12 for Europe).
With both ROMs i have problems with Bluetooth connection together with BT mouse Wintec 201 (but i heared the same from Holux owners too).

If i try to connect via "bluetooth" i get the error 779.
But the connection via "rfcn0" is possible. But now PW does not remind the used BT HW and is asking me everytime if i want to connect PW with the Wintech which BT HW i want to use.

Together with a german PALM developer who has written a PALM tool for the Wintech we faced theat the BTSerial is sending messages every second, but BTSerialPro sends the first message, then we have a break over one second before the next messages sent.
If we have a deeper look to error 779 we are thinking we should convert it into 700 and 79. And D'79 = H'4F with the meaning:

#define btLibL2DiscRequestTimeout (blthErrorClass | 0x4F)// An L2CAP request timed out.

What dou you think, may this possible and can you fix it?

I tried it with PW 4.079.

Can you check this please.

Thanks and Regards
Matthias

alonhzn
Posts: 2
Joined: Thu Feb 14, 2008 2:37 am

Postby alonhzn » Thu Feb 14, 2008 2:42 am

Hi,

I have exactly the same problem with my Treo680 + RBT1000 GPS.
I get err 779.
Is there a solution to the problem?
what if I somehow revert to the old ROM (1.04 i think)?

Thanks


UPDATE:
I Installed custom ROM Version 1.09 from:
http://discussion.treocentral.com/showt ... p?t=144028
and it works!!
it seems that Palm really changed something they shouldn't have in the last ROM version.
I guess the new version is better but i prefer a working GPS...

palmerl
Posts: 1
Joined: Thu Nov 15, 2007 1:03 pm

Postby palmerl » Sat Feb 16, 2008 2:19 pm

Hello,

I am having the same trouble with Port : Bluetooth after the rom update.
However as stated above rfcn does work.

Regards,
Larry

Treo 680
New Rom update from Treocentral
Navibe GPS receiver

Scooby
Posts: 17
Joined: Tue Feb 06, 2007 12:23 am

Postby Scooby » Sat Feb 16, 2008 10:43 pm

@palmerl

How does it work?
I'm using rfcn too. But now, everytime the treo is connecting with the BT-mouse, i have to choose the mouse from the list of BT devices.
With the old ROM and using port Bluetooth, this was necessary only the first time and then never again.
How looks this at your treo?


Regards
Matthias

User avatar
Scott
Site Admin
Posts: 1033
Joined: Mon Apr 18, 2005 8:49 pm
Location: Ontario, Canada
Contact:

Postby Scott » Tue Feb 19, 2008 3:20 am

Re:
I tried it with PW 4.079, but now back to PW 4.065, because in
079 track import is impossible (error code 1).


Note: 4.00.80 will fix the tracking problem. It is unfortunate that Palm seems to have broken some of the Bluetooth Comm in newer firmware. (As well the ports for bluetooth have changed, so we only know you are using Bluetooth (and then can remember the settings) when the port named "Bluetooth" is used. We'll see if there is possibly a workaround for this.

We'll also look at the suggested fix for the error 779 msg.

Scooby
Posts: 17
Joined: Tue Feb 06, 2007 12:23 am

Postby Scooby » Wed Feb 20, 2008 1:19 am

Hi Scott,

thanks, thats fine.


Regards
Matthias

User avatar
Scott
Site Admin
Posts: 1033
Joined: Mon Apr 18, 2005 8:49 pm
Location: Ontario, Canada
Contact:

Postby Scott » Sat Feb 23, 2008 9:15 pm

I also found this FAQ on the Emtac GPS support page at http://www.emtac.com/ens4support.html

Attention Treo 680 Customers!

Reports are coming in from customers that after performing the ROM updates from Palm for the Treo 680, EMTAC Navigator is unable to connect to the Bluetooth GPS.

If you are an EMTAC Navigator customer considering the Treo 680 update, please do not perform the update. Doing so may render EMTAC Navigator unusable on your device.

We will continue to look into this issue and post more information when it becomes available.


Scooby
Posts: 17
Joined: Tue Feb 06, 2007 12:23 am

Postby Scooby » Sun Feb 24, 2008 7:32 pm

Yes, it seems that with the new TREO ROM now all navigiation SW has got big problems.
My TomTom is also affected. It does not working after the upgrade.

But PW 4 is still working! Only the remember of the other used BT port is the issue. May be this can be fixed.

Thanks and regards
Matthias

SMA
Posts: 2
Joined: Sat Mar 08, 2008 4:06 pm
Location: Egypt

Postby SMA » Sat Mar 08, 2008 4:15 pm

I am using a Holux GR-230 and I have the same problem since the ROM upgrade of my Palm Treo 680.

I am also using a small soft (GPS tester), which is giving the GPS coordinates, receiving the datas from the receiver via Bluetooth. It is working.

I am very interesting to get a solution to have Pathaway working with my treo. I am using it almost every week-end to go to the desert.

ualcaptainron
Posts: 1
Joined: Tue Mar 11, 2008 2:53 am
Location: MS

error 779 on Treo 700p

Postby ualcaptainron » Tue Mar 11, 2008 3:05 am

I just replaced my Treo 650p with a Treo 700P with the current ROM update. I use a Holux GPSlim 240 . I suppose my error 779 problem is related to the ROM as well. I don't want to install an outdaded ROM. I hope we get an updated Pathaway program to fix this problem.

Scooby
Posts: 17
Joined: Tue Feb 06, 2007 12:23 am

Postby Scooby » Sun Mar 16, 2008 7:19 pm

Hi Scott,

meanwhile i replaced my Treo 680 by Centro.
But it is the same issue as with the Treo. Error 779 if I'm using "bluetooth" or in case of "rfcn1" PW does not remenber to the BT device.
So it seems that all newer Palm devices having this problem.
Please try to fix it.

Thanks a lot
Matthias

User avatar
RaNo
Posts: 5
Joined: Tue May 20, 2008 11:57 pm
Location: Krakow, Poland
Contact:

Postby RaNo » Wed May 21, 2008 2:32 am

To everyone getting this problem, this thread might also be interesting.

To the developer of PathAway: please also refer to that thread to learn how you can easily fix this bug.


Return to “PathAway GPS 4 SE for Palm OS - Support”

Who is online

Users browsing this forum: No registered users and 3 guests