Lifedrive loses Bluetooth GPS connection

Questions and problems regarding connecting GPS Receivers.

Moderators: Scott, PathAway

Posts: 2
Joined: Fri May 26, 2006 10:59 pm

Quick erase

Postby difermo » Fri May 26, 2006 11:17 pm

I'm new to PDAs, GPS and forums! ... I'm an owner of a lifedrive for the past 4 days only.

I have a bluetooth GPS receiver by f-tech.
I used both cotoGPS and GPS tester programmes to test the GPS connection.

I experienced the same problems like described in this thread.
The communication between the LD and GPS stops after about 10 minutes in case of a soft-reset or after just 1 or 2 minutes in case I put the bluetooth off and on again and re establish communication without performing a soft reset (but the bluetooth on the LD would perform slowly is no soft reset is performed).

Following the comment by scott, I contacted palm help and they adviced that it could be a software conflict. Hence I followed the instuctions to perform a backup, then a quick erase and finally reload the contacts, calendar and tasks. This erased all programmes I had installed... not much just bejeweled 2, michelin red guide, cotoGPS and GPS tester.

I then installed GPStester and established a connection.
So far, the connection went on without stopping. I also tried to place the GPS receiver away from the LD, drop the connection and connect again. Connection was re established and so far is kept on running.

Will continue trying until I find out which conflict stopped the communication.

Will keep you posted.


Posts: 13
Joined: Wed Feb 22, 2006 9:11 pm
Location: Belgium

Postby Guido » Wed May 31, 2006 9:58 pm

Thank you very much, Difermo for your advice.
Will you keep us informed, please?
In between I experienced that TomTom gives no problems at all. Pathaway, Cotogps en Thatway, they all have the same problem.
I experienced a little bit with enlarging the buffer (configure gps, advanced) to the maximum value of 99999 kb en I thinks that the connection time is longer no ...


Posts: 2
Joined: Fri May 26, 2006 10:59 pm

BT GPS Receiver, loosing connection.

Postby difermo » Thu Jun 01, 2006 9:57 am

The loss of communication seems to be limited to the cotoGPS programme. The GPStester kept on going. Once I've installed again cotoGPS (without running it), GPStester started to drop communication.
Needless to say that also cotoGPS would do the same.

Hence I removed cotoGPS from my LD and testerGPS worked perfectly again.

I tried to locate more freeware software over the net to check for bluetooth GPS connection. But alas.... only GPStester and cotoGPS would start communication with my bluetooth GPS device.

Guido, could it be that cotoGPS (and Pathaway etc) use bt libraries not compatible with LD?
I tried to contact the author of cotoGPS, but so far I had no reply from him. At Palm, they told me that even though both TX and LD have PalmOS 5.4, each device is different and also include different built-in applications.

Thanks for the info about TomTom. Searching over the net, it seems that also ViaMichelin have some issues with LD.


Posts: 1
Joined: Wed Mar 12, 2008 4:45 pm


Postby mnc » Wed Mar 19, 2008 5:09 pm

Hey guys. I read this entire thread with some hope, but the hope is gone in the end of it :(

I'm experiencing the same problem here in Brazil, and it's really something to do with BTLIB driver of Lifedrive.
I've tested many configurations, many "try-and-see" things, and I can give you some hints on how to avoid this problem (sometimes...)

- Reduce track log sizes, increasing the time between points (10 secs or more), and speed about to check points (10 meters I'm using). Of course, this advice only works for cars trips. Explanation: It seems the BT freeze problem has something to do with hard drive updates frequency.
- Install some DB cache cleaner (like FlushIT!). I've noticed that when I clean the cache before running pathaway it doesn't lock BT.
- When you got the problem (freeze), you don't need to reset the device. Turn pathaway gps connection OFF (if you got the no gps response message, it already gone), turn bluetooth OFF (it will take about 30secs to do it), turn BT on again, and restart gps connection on pathaway. Works, garanteed!

That's it. If someone find out the real solution for this problem, please let me know!

Return to “GPS Receiver Support”

Who is online

Users browsing this forum: No registered users and 2 guests